Do you like this site? Remember to share it to all your friends on Facebook and Twitter!

Saturday, June 27, 2009

Dual Stack IPv6 and IPv4 configuration (CNA-04-006)

CCNA Exploration 4.0, Semester 4, "Dual Stack IPv6 and IPv4 configuration " Packet Tracer 5.0 practice file (CNA-04-006).





This example is designed for you to practice basic IPv6 commands in IOS. You will also know the new fashion to start a routing protocol in IPv6.

Note: Packet Tracer 4.X does not support IPv6. Please use version 5.X and later to practice IPv6.

To simplify your task, I configured all the necessary IPv4/IPv6 addresses on the interfaces. You can just begin to observe and verify!



interface FastEthernet0/0
 ip address 10.1.1.1 255.255.255.0
 duplex auto
 speed auto
!
interface FastEthernet0/1
 no ip address
 duplex auto
 speed auto
 ipv6 address 2001:1:1:1::1/64
!
interface Serial0/0/0
 ip address 10.2.2.1 255.255.255.0
 ipv6 address 2001:2:2:2::1/64
 clock rate 64000
!

You have to configure "routing protocol" yourself. To verify "Dual Stack", we will enable both IPv4 routing protocol and IPv6 routing protocol.

The IPv4 part (in this case, RIPv2) is very easy for you. Remember the basic two steps to start any IPv4 routing protocols in IOS:

  1. Use one "router X" command, to start one routing protocol process
  2. Use one or more "network Y" commands, to specify at which interfaces will this protocol being enabled

So the configuration is this:

router rip
 version 2
 network 10.0.0.0
 no auto-summary
!

For this simple IPv4 addressing, it is not necessary to include an "no auto-summary" command. It is always a good habit to add "no auto-summary" in today's VLSM world.

As to IPv6 part (RIPng), steps are quite different from IPv4:

  1. We need to start the routing protocol process first. In addition, we also have to create a TAG name for it. This is because in IPv6 IOS supports multiple instances on routing protocols
  2. Go directly to interface configuration mode to assign which "routing instance" to be enabled on this interface.


interface FastEthernet0/1
 no ip address
 duplex auto
 speed auto
 ipv6 address 2001:1:1:1::1/64
 ipv6 rip CCNA enable 
!
interface Serial0/0/0
 ip address 10.2.2.1 255.255.255.0
 ipv6 address 2001:2:2:2::1/64
 ipv6 rip CCNA enable 
 clock rate 64000
!
interface Serial0/0/1
 no ip address
 shutdown
!
ipv6 router rip CCNA
!

In fact, the tag name "CCNA" is only locally significant. You can play by using different tags on two routers and verify it yourself.
Do you like this post? You really should consider Subscribing by Email!


Related Posts with Thumbnails

38 comments:

  1. HI...
    i was just trying to create a ipv6 n\w on packet tracer. The problem is that the host pc,laptop and server int packet tracer does not save the ipv6 add and the default gateway configuration despite of saving the topology each time i exit. This is creating a problem of adding the ipv6 add each time.
    I use packet tracer 5.2.

    Please help!!!

    ReplyDelete
  2. I tested and I found the same problem as you did, both in version 5.0 and 5.2. I think this is a bug of Packet Tracer!

    I did find one possible workaround as far as I tested: if you did not switch any PC's IPv6 address/IPv6 default gateway to "Auto Config" at all, keeping it to be "Static" as default, configuration of IPv6 static addresses will be successfully saved!

    Once you have switched to "Auto Config" on one PC, even you have change back to "Static" later, the problems will from now on persist!

    My example Packet Tracer 5.0 files in this post exactly support this possible workaround. The IPv6 addresses on PCs/Servers are correctly saved!

    ReplyDelete
  3. hi thank you for sharing your information
    but i have aproblem in packet tracer 5.02
    when i select router 2811 id dosent have a serial interfaces just have ethernet and console
    so i couldent connect two routers with serial link please help me

    ReplyDelete
  4. No worry! You absolutely can do this in Packet Tracer 5.

    After you put on two 2811 routers, "switch power off" them first. You can then add WIC-1T or WIC-2T interface cards on them, and add one serial cable at the interfaces between them. At last turn both routers' power back on. Done!

    A tip for you about using Packet Tracer: try searching YouTube with keyword "Packet Tracer". You will find so many guided videos for Packet Tracer to help you.

    I wish above information is helpful! Drop me an Email anytime if I could be of help!

    ReplyDelete
  5. HI again ,thank you for your information
    but i have a quation does cisco router 2800 support ipv6 address and protocols ,i mean doing your work above (dual stack ipv4/ipv6 ) by using
    cisco router 2800 practically.

    ReplyDelete
  6. Hi,
    I am having some trouble pingging from a host pc towards a router using ipv6 addressing. for Information:

    I'm using the command prompt to do so:
    PC>ping 2001:1:1:1::1

    Unfortunately it does not work
    PS: i'm using packetTracer 5.2.1 and the solution file you provided above

    Any suggestions ???
    Thx

    ReplyDelete
  7. (1) The real Cisco routers such as 2800 series do support IPv6, but you must have good IOS software to enable it! For 2800, you must have "Advanced IP Service" or better IOS images booted. I would like to remind you that such IOS image is not free from Cisco.

    Of course, Packet Tracer does not want to distract you with such buying details, so its "virtual" 2800 always comes with sufficient IOS.

    (2) I tested again the IPv6 in this PKT file is working.

    In this example, only PC1 and Server1 (at bottom) are IPv6 enabled. PC0 and Server0 (upper) are only IPv4 enabled. I arranged this way to show Cisco router is indeed "Dual Stack": 2 protocols running independently at the same time.

    Could it happen to you that you tested IPv6 on PC0 or Server0? Please try IPv6 on PC1 and Server1 instead!

    ReplyDelete
  8. hi i am an IT college student , i have a project which is implement rip in ipv6 using dual stack (the same as your work above)but my work in mobile ipv6 can you give me some information about how i can do it ,and can i do it using packet tracer or other network simulation please help me.

    ReplyDelete
  9. Mobile IPv6 is quite an advanced topic and not supported in Packet Tracer. To setup the lab environment, you will need at lease 3 or more routers. Do you know what Dynamips is? Maybe it could save you some time cabling your lab. As to Mobile IPv6 itself, you can start on this page: Implementing Mobile IPv6

    You can mail your questions to me anytime when you need help!

    ReplyDelete
  10. hi i have a cisco router 2800 series and ios image version 12.4 (3g) did it support ipv6 address, when i check the command ipv6 unicast-routing it doesnt work .please help

    ReplyDelete
  11. Hi! If you cannot issue this command, I could only recommend you to upgrade your IOS.

    You can do "show version" again to identify the package of your IOS image. It should be above "Advanced IP Services" to support IPv6.

    Refer to this page (the same for Routers). Cheers!

    ReplyDelete
  12. I am asking for help with configuration of manual tunnel ipv6ip in Packet Tracer 5.2. I cannot configure a command for interface tunnel 0 IPv6 address in the router 2811. It does not recognize the command at all even if ipv6 unicast-routing is turned on.



    look:

    Router#configure terminal
    Router(config)#ipv6 unicast-routing
    Router(config)#interface tunnel 0
    Router(config-if)#ipv6 address 2001:db8:1:fff::/64
    ^
    % Invalid input detected at '^' marker.

    Router(config-if)#





    please help

    ReplyDelete
    Replies
    1. Router(config-if)#ipv6 address 2001:db8:1:fff::/64 <== wrong
      Router(config-if)#ipv6 address 2001:db8:1:fff::1/64 <== true

      XD

      Delete
  13. You are right! Neither can I. I believe such feature will come out in future releases!

    For urgent practice: try Dynamips! (You are preparing for BSCI in CCNP, right?)

    ReplyDelete
  14. thank for your response but didnt you know any network simulation that i can use for implement ipv6 tunneling exept packet tracer

    ReplyDelete
  15. I mentioned, Dynamips. Maybe you should try GNS3 first, which provides GUI front end and uses Dynamips as core.

    As a reminder, IOS to Dynamips is just like Windows to Virtual PC. You will need a valid IOS image before starting all your Dynamips labs. Cheers!

    ReplyDelete
  16. how to enable both IPv4 and IPv6 Routing Protocols (RIPv2 and RIPng) on R1 and R2
    to service full connectivities for both worlds?

    ReplyDelete
  17. If you follow the steps in the post, you will get full connectivities for each of IPv4 and IPv6 world, independently. This is what "dual stack" designed for.

    If what you asked is about mixing the connectivity between IPv4 and IPv6 world, it is not possible with Cisco routers, as far as I know of. Mixing IPv4 and IPv6 worlds requires "protocol translator" and not covered in this post!

    ReplyDelete
  18. hi how are you
    i want a advise about what best simulator support mobile ipv6?
    i want to implemented mobile ipv6 networks
    i only know opnet but didnt you know others

    ReplyDelete
  19. To Anonymous:

    To be honest, I do not have any better solutions by hand. I will try my best to find them and update here!

    Thanks for raising this interesting question!

    ReplyDelete
  20. thanks
    i will be waiting

    ReplyDelete
  21. use packet tracer 5.3 ..this solves the problem ..

    ReplyDelete
  22. hi again sorry if i bother you
    but what cisco router support mobile ipv6
    is there is specific version or it should be
    wireless router , can wired router support it
    like 2811

    ReplyDelete
  23. To Anonymous: You can refer to this page for details.

    To be short, any platform has 12.4 and above (also above Advanced IP Services package for safe) should support Mobile IPv6.

    Your 2811 box is good enough. You only need a good IOS!

    I'd like to remind you that Mobile IPv6 has nothing to do with "wireless or wired"! Mobility here means the freedom of addressing: not bound to any physical subnets. Cheers!

    ReplyDelete
  24. To xecutioner: Thanks for your suggestion! PT 5.3 is really great for many IPv6 labs!

    As to Mobile IPv6, I tested again but it is still not supported in PT 5.3 yet. I hope to see it soon!

    ReplyDelete
  25. To Anonymous, about Mobile IPv6 Simulation:

    I searched in Google and found some possible alternatives to OPNET:

    [OMNeT++]
    http://www.omnetpp.org/

    [The ns-3 network simulator]
    http://www.nsnam.org/

    I have not tried them out to tell which one is the best for you!

    ReplyDelete
  26. in the packet tracer how do you configure the pc address for ipv6, i can only select ipv4 address and i have the static ipv6 address but cant see where to put the pc ipv6 address. Thanks I know it probably something so simple i am missing

    ReplyDelete
  27. @Anonymous Which version of Packet Tracer did you use? I remember IPv6 is supported only after PT 5.0.

    It should be right at "Config" tab. Or you can click on the "Interface" section of "Config" tab.

    ReplyDelete
  28. Thanks found it just after i posted this up. Have you done any configurations for nat-pt in packet tracer, i am really under pressure to get it working and I have spent many late nights trying to work it out. Any help greatly appreciated.

    ReplyDelete
  29. @Anonymous As far as I have tested, I have no luck about NAT-PT on Packet Tracer 5.3.X, either!

    Even NAT-PT relevant commands are there, in my test PT just hang itself.

    ReplyDelete
  30. Li-Ji.

    This is great. It works fine on Packet tracer 5.3.

    Thanks for your help.
    Keep up the good work.

    ReplyDelete
  31. Does dual stack mean, an interface which is capabale of receiving/transmitting IPv4 & IPv6

    ReplyDelete
  32. @Nazeer That's correct! Also, both IPv4 and IPv6 operate independently on any interfaces.

    You may simply consider a dual-stack router as one router hardware with two separate contexts (brains)!

    ReplyDelete
  33. hi i'm an engg student. i'm in 2nd year. i would like to know is there any basic course in networking under CISCO certification

    ReplyDelete
  34. @Anonymous If you are a student I suggest you to take Cisco Network Academy courses.

    Many colleges around the world provide CNA courses. Maybe your school is one of them. Some colleges recognize the credits for your graduation. This is also the most economical way to get Cisco certifications.

    I suggest you to check Cisco's web for more information.
    http://www.cisco.com/web/learning/netacad/index.html

    ReplyDelete
  35. Hello please how could I communicate between ipv4 and ipv6?I thouth the whole reason behind dual-stack is to allow communication between the two protocols

    ReplyDelete
    Replies
    1. @Yasir Almost all clients and servers are IPv6 dual-stacked today. Maybe it is not that necessary to "allow communication" between IPv4 and IPv6, in my opinion!

      Delete

Tip: you can also anonymously comment here.

Popular Posts