In this example, I am building two external BGP peering relationships. One is going from WAN and the other is going from LAN.
Notes about this example
I just want to save some typing defining neighbors, so I changed all link local addresses to simpler ones. This is not necessary for link local peering to work.
Remember to also define "neighbor update-source”, so IOS could know with which interface to start the BGP’s TCP connection.
Key Configuration of R1
interface FastEthernet0/0
no ip address
duplex auto
speed auto
ipv6 address FE80::3 link-local
ipv6 enable
!
interface Serial0/0
no ip address
ipv6 address FE80::1 link-local
ipv6 enable
clock rate 2000000
!
interface FastEthernet0/1
no ip address
duplex auto
speed auto
ipv6 address 2000:1:1:1::1/64
!
router bgp 65500
no synchronization
bgp router-id 1.1.1.1
bgp log-neighbor-changes
neighbor FE80::2 remote-as 65400
neighbor FE80::2 update-source Serial0/0
neighbor FE80::4 remote-as 65400
neighbor FE80::4 update-source FastEthernet0/0
no auto-summary
!
address-family ipv6
neighbor FE80::2 activate
neighbor FE80::4 activate
network 2000:1:1:1::/64
exit-address-family
!
Key Configuration of R2
interface FastEthernet0/0
no ip address
duplex auto
speed auto
ipv6 address FE80::4 link-local
ipv6 enable
!
interface Serial0/0
no ip address
ipv6 address FE80::2 link-local
ipv6 enable
clock rate 2000000
!
interface FastEthernet0/1
no ip address
duplex auto
speed auto
ipv6 address 2000:2:1:1::1/64
!
router bgp 65400
no synchronization
bgp router-id 2.2.2.2
bgp log-neighbor-changes
neighbor FE80::1 remote-as 65500
neighbor FE80::1 update-source Serial0/0
neighbor FE80::3 remote-as 65500
neighbor FE80::3 update-source FastEthernet0/0
no auto-summary
!
address-family ipv6
neighbor FE80::1 activate
neighbor FE80::3 activate
network 2000:2:1:1::/64
exit-address-family
!
BGP Neighbors on R1
R1#show bgp ipv6 unicast summary
BGP router identifier 1.1.1.1, local AS number 65500
BGP table version is 3, main routing table version 3
2 network entries using 298 bytes of memory
3 path entries using 228 bytes of memory
3/2 BGP path/bestpath attribute entries using 372 bytes of memory
1 BGP AS-PATH entries using 24 bytes of memory
0 BGP route-map cache entries using 0 bytes of memory
0 BGP filter-list cache entries using 0 bytes of memory
BGP using 922 total bytes of memory
BGP activity 2/0 prefixes, 3/0 paths, scan interval 60 secs
Neighbor V AS MsgRcvd MsgSent TblVer InQ OutQ Up/Down State/PfxRcd
FE80::2 4 65400 7 7 3 0 0 00:02:16 1
FE80::4 4 65400 7 7 3 0 0 00:02:25 1
R1#
BGP Table on R1
R1#show bgp ipv6 unicast
BGP table version is 3, local router ID is 1.1.1.1
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,
r RIB-failure, S Stale
Origin codes: i - IGP, e - EGP, ? - incomplete
Network Next Hop Metric LocPrf Weight Path
*> 2000:1:1:1::/64 :: 0 32768 i
* 2000:2:1:1::/64 FE80::4 0 0 65400 i
*> FE80::2 0 0 65400 i
R1#
Connectivity Verification
R1#show ipv6 route
IPv6 Routing Table - 5 entries
Codes: C - Connected, L - Local, S - Static, R - RIP, B - BGP
U - Per-user Static route
I1 - ISIS L1, I2 - ISIS L2, IA - ISIS interarea, IS - ISIS summary
O - OSPF intra, OI - OSPF inter, OE1 - OSPF ext 1, OE2 - OSPF ext 2
ON1 - OSPF NSSA ext 1, ON2 - OSPF NSSA ext 2
C 2000:1:1:1::/64 [0/0]
via ::, FastEthernet0/1
L 2000:1:1:1::1/128 [0/0]
via ::, FastEthernet0/1
B 2000:2:1:1::/64 [20/0]
via FE80::2, Serial0/0
L FE80::/10 [0/0]
via ::, Null0
L FF00::/8 [0/0]
via ::, Null0
R1#
R1#ping 2000:2:1:1::1 source F0/1
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 2000:2:1:1::1, timeout is 2 seconds:
Packet sent with a source address of 2000:1:1:1::1
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 16/32/48 ms
R1#
No comments:
Post a Comment
Tip: you can also anonymously comment here.